#OpenBSD
net.bpf.bufsize=2097152
net.bpf.maxbufsize=4194304
net.inet.tcp.recvspace=65535
net.inet.tcp.sendspace=65535
net.inet.ip.maxqueue=2048
kern.somaxconn=2048
net.bpf.bufsize=2097152
net.bpf.maxbufsize=4194304
net.inet.ip.portfirst=32768
net.inet.ip.portlast=49151
net.inet.ip.porthifirst=49152
net.inet.ip.porthilast=65535
kern.shminfo.shmmax=67018864
kern.shminfo.shmall=32768
#FreeBSD 8.0
net.inet.tcp.inflight.enable=1
net.inet.tcp.inflight.min=6144
net.inet.tcp.inflight.max=1073725440
net.inet.tcp.inflight.stab=20
net.inet.tcp.recvspace=65536
net.inet.ip.redirect=0
net.inet.tcp.syncookies=1
net.inet.tcp.delayed_ack=0
kern.coredump=0
kern.maxfiles=65536
kern.maxfilesperproc=32768
kern.maxprocperuid=16384
kern.ipc.maxsockbuf=2097152
kern.ipc.nmbclusters=32768
net.inet.udp.maxdgram=57344
kern.threads.max_threads_per_proc=40000
kern.threads.max_groups_per_proc=40000
net.inet.ip.portrange.first=32768
net.inet.ip.portrange.last=49151
net.inet.ip.portrange.hifirst=49152
net.inet.ip.portrange.hilast=65535
kern.ipc.somaxconn=1024
kern.ipc.shmmax=67108864
kern.ipc.shmall=32768
net.inet.ip.maxfragpackets=1600
#FreeBSD Older Versions (Check your sysctl values)
net.tcp.inflight.enable=1
net.inet.tcp.inflight.min=6144
net.inet.tcp.inflight.max=1073725440
net.inet.tcp.inflight.stab=20
net.inet.tcp.recvspace=65536
net.inet.ip.redirect=0
net.inet.tcp.syncookies=1
net.inet.tcp.delayed_ack=0
kern.coredump=0
kern.maxfiles=65536
kern.maxfilesperproc=32768
kern.maxprocperuid=16384
kern.ipc.maxsockbuf=2097152
kern.ipc.nmbclusters=32768
net.inet.udp.maxdgram=57344
kern.threads.max_threads_per_proc=40000
kern.threads.max_groups_per_proc=40000
net.inet.ip.portrange.first=32768
net.inet.ip.portrange.last=49151
net.inet.ip.portrange.hifirst=49152
net.inet.ip.portrange.hilast=65535
kern.ipc.somaxconn=1024
kern.ipc.shmmax=67108864
kern.ipc.shmall=32768
net.inet.ip.maxfragpackets=1600
#Good settings for updating stuff
#NOTE: Make sure to pick servers close to you.
CVSROOT=anoncvs@anoncvs1.usa.openbsd.org:/cvs
export CVSROOT
PKG_PATH=ftp://ftp.openbsd.org/pub/OpenBSD/4.4/packages/i386/
export PKG_PATH
#First checkout the source
cd /usr
cvs -qd anoncvs@anoncvs.ca.openbsd.org:/cvs get -rOPENBSD_4_4 -P src
cd /usr
cvs -qd anoncvs@anoncvs.ca.openbsd.org:/cvs get -rOPENBSD_4_4 -P ports
#Get Source
cd /usr/src;
cvs -q up -rOPENBSD_4_4 -Pd;
#Get Ports
cd /usr/ports;
cvs -q up -rOPENBSD_4_4 -Pd;
#Rebuilding the kernel
#To rebuild the default kernel from stable:
cd /usr/src/sys/arch/i386/conf
/usr/sbin/config GENERIC
cd /usr/src/sys/arch/i386/compile/GENERIC
make clean && make depend && make
#Replace i386 with your architecture, e.g. sparc, alpha, etc.
#Rebooting with the new kernel
#To reboot with the newly compiled kernel:
cd /usr/src/sys/arch/i386/compile/GENERIC
cp /bsd /bsd.old (Save an old copy of your kernel)
cp bsd /bsd (Copy the new kernel into place)
reboot
#As above, substitute your architecture for i386. If your system has trouble booting the new kernel, you can easily go back and reboot from the old kernel, now called bsd.old.
#Rebuilding the binaries
#To rebuild the system binaries:
rm -rf /usr/obj/*
cd /usr/src
make obj
cd /usr/src/etc && env DESTDIR=/ make distrib-dirs
cd /usr/src
make build
#This will take awhile...
#FreeBSD install 6.3(WuTang Style)
#OS
cvsup supfile && cd /usr/src && make buildworld && make buildkernel KERNCONF=foo && make installkernel && make installworld && reboot
#Ports
cvsup ports && cd /usr/ports/pathto/port && make deinstall && make install clean
#FreeBSD install 7.2 (Updated Style)
#Binary only updates:
freebsd-update fetch install
#The Real Deal
csup -g -L 2 /etc/stable-cvsup.conf && cd /usr/src && make buildworld && make buildkernel KERNCONF=FOO && make installkernel KERNCONF=FOO && mergemaster -pai && make installworld && make delete-old && mergmaster -Uai && reboot
#Port Updates:
portaudit -Fda
portsnap fetch extract
portupgrade -fa
www.shirkdog.us
No comments:
Post a Comment